Saturday, November 5, 2016

Dynamic Routing

OSPF Features
OSPF Hierarchy
configuring and Verifying OSPF



OSPF Details

Link State Protocol
100% loop free topology
Fast convergence
Classless routing - understands variable length subnet mask (VLSM)
Use Cost (Bandwidth) as Metric
Sends Partial updates only LSA - only when network change
Administrative Distance is 110



router(config)# router ospf <process-id> -  internal number on router
router(config-router)# network <network> <wildcard-mask> area <area-id>  - start helo packets


Example

routerA(config)# router ospf 5
routerA(config-router)# network 192.168.1.0 0.0.0.0.5 area 0
routerA(config-router)# network 12.12.12.0 0.0.0.0.5 area 0
routerA(config-router)# network 13.13.13.0 0.0.0.0.5 area 0



OSPF configuration

routerA  Fe0/1 192.168.1.1/24, S0/0/0 12.12.12.1/24, S0/0/1 12.12.12.1/24
routerB  Fe0/1 192.168.2.1/24, S0/0/0 12.12.12.2/24, S0/0/1 13.13.13.1/24
routerc  Fe0/1 192.168.3.1/24, S0/0/0 12.12.12.2/24, S0/0/1 13.13.13.1/24



OSPF Configuration Verification

routerA# show ip protocols   (displays info about all routing protocols running on the router)
routerA# show ip route        (displays the routing table of the router)
routerA# show ip ospf neighbor (displays the OSPF neighbor Table)
routerA# show running-config   (Displays the Routers running configurations)




Redistribute a static or directly connect routes into OSPF 

MUST follow this order
1. create prefix list
2. create router map
3. create ospf redistribution

see example in router

Step 1
ip prefix-list connected_into_ospf seq 5 permit 10.85.246.2/32  (prefix listed for the router map)
!
ip prefix-list static_into_ospf seq 5 permit 10.85.246.128/25



Step 2
!
route-map connected_into_opsf permit 10
 match ip address prefix-list connected_into_opsf
 set tag 1002
!



Step 3

router ospf 3768
 log-adjacency-changes
 area 853 authentication message-digest
 redistribute connected metric-type 1 subnets route-map connected_into_opsf
 redistribute static metric 1 subnets route-map static_into_ospf
 passive-interface Loopback0
 network 10.85.246.12 0.0.0.3 area 853